June 15, 2014

Ubuntu14.04にJulia 0.3をインストールした

https://launchpad.net/~staticfloat/+archive/julianightliesよりPPAを追加した。

$ sudo apt-get update

$ sudo apt-get upgrade

$ sudo apt-get install julia

パッケージリストを読み込んでいます... 完了

依存関係ツリーを作成しています                

状態情報を読み取っています... 完了

インストールすることができないパッケージがありました。おそらく、あり得

ない状況を要求したか、(不安定版ディストリビューションを使用しているの

であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移

動されていないことが考えられます。

以下の情報がこの問題を解決するために役立つかもしれません:



以下のパッケージには満たせない依存関係があります:

 julia : 依存: libcholmod1.7.1 しかし、インストールすることができません

         依存: libumfpack5.4.0 しかし、インストールすることができません

         依存: librmath-julia-dev しかし、インストールすることができません

E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

と表示された。

パッケージ: libcholmod1.7.1 (1:3.4.0-1ubuntu3) ,パッケージ: libcolamd2.7.1 (1:3.4.0-3ubuntu1)

$ wget http://kr.archive.ubuntu.com/ubuntu/pool/main/s/suitesparse/libcholmod1.7.1_3.4.0-1ubuntu3_amd64.deb

$ wget http://kr.archive.ubuntu.com/ubuntu/pool/main/s/suitesparse/libcolamd2.7.1_3.4.0-3ubuntu1_amd64.deb

$ wget http://kr.archive.ubuntu.com/ubuntu/pool/main/s/suitesparse/libamd2.2.0_3.4.0-1ubuntu3_amd64.deb

$ wget http://kr.archive.ubuntu.com/ubuntu/pool/main/s/suitesparse/libumfpack5.4.0_3.4.0-3ubuntu1_amd64.deb

としてから、dpkg -i でパッケージをインストールしたんだが、

$ sudo apt-get install julia

パッケージリストを読み込んでいます... 完了

依存関係ツリーを作成しています                

状態情報を読み取っています... 完了

インストールすることができないパッケージがありました。おそらく、あり得

ない状況を要求したか、(不安定版ディストリビューションを使用しているの

であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移

動されていないことが考えられます。

以下の情報がこの問題を解決するために役立つかもしれません:



以下のパッケージには満たせない依存関係があります:

 julia : 依存: librmath-julia-dev しかし、インストールすることができません

E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

となってしまった。バイナリでインストールするのを諦めたので、ソースコードから自分でコンパイルする方法を試してみた。

過去にJuliaをインストールした時のJuliaのインストールを参考に、

$ git clone https://github.com/JuliaLang/julia.git

$ cd julia

$ make

$ sudo paco -D "cp -r usr/* /usr/local"

90分ぐらいの時間がかかった。

© gepuro 2013